Docs
API7 GatewayReleases and supportRelease Notes3.8.0

API7 Gateway 3.8.0

AI Proxy — Implemented new identifier fields logging and summaries for collecting LLM request and response content.

Release Date: 2025-04-22

Features

Plugins

Data Plane

  • Supported using values from an array object within the user request body in routing conditions. While post_arg was already permitted in routing conditions, this update introduces support for array scenarios for the type field's location.
  • Supported the recording of additional AI request context information within access logs.
  • Supported adding a request type identifier to Prometheus metrics to collect more granular data on AI requests.

Console (Dashboard)

  • Added detailed statistics for service name and route name in status code alert messages.
  • Optimized plugin configuration: When configuring Traffic Split (opens in Plugin Hub docs) plugin on a service or route, verify that the upstream_id configured indeed belongs to the current service's upstreams.
  • Aligned the upstream connection configuration field names with the API in published services.
  • Introduced a form-based UI for CORS (opens in Plugin Hub docs) plugin configuration.

Fixes

Data Plane

  • Fixed issue: When the upstream type was Kubernetes service discovery, nodes in health checks were not updated after node changes, resulting in many health check failure logs.
  • Fixed issue: An error occurred when the shared_size parameter for Kubernetes service discovery was adjusted to 100m.#11857
  • Fixed issue: APISIX/API7 Enterprise with Kubernetes discovery will fail after token file expires. #11779
  • Fixed issue: After updating the prefix of Vault secret provider, the data plane continued to use the old configuration.

Console (Dashboard)

  • Fixed issue: The retries field in the upstream was incorrectly set as required.
  • Fixed issue: An error occurred on the published service page due to lack of service template permissions.
  • Fixed issue: Updating the service discovery service name in published services did not take effect.
  • Fixed issue: Creating multiple records with rapid clicks.
  • Fixed issue: High database CPU utilization when using large scale of consumers.
  • Optimized the wildcard configuration method for Permission Policy:
    • Wildcard configuration using * is now supported in authorization statements, with the same meaning as the current <.*>;
    • The asterisk * is restricted and not allowed in any resource ID fields to prevent authorization failures.