API7 Gateway 3.8.0
AI Proxy — Implemented new identifier fields logging and summaries for collecting LLM request and response content.
Release Date: 2025-04-22
Features
Plugins
- AI Proxy (opens in Plugin Hub docs)
- Implemented new identifier fields
loggingandsummariesfor collecting LLM request and response content.
- Implemented new identifier fields
- AI Proxy Multi (opens in Plugin Hub docs)
- Supported HTTP POST method for health checks.
- Displayed a record at the warning log level if the fallback was triggered.
- Implemented a new identifier field for collecting LLM request and response content.
- AI Aliyun Content Moderation (opens in Plugin Hub docs)
- Added support for streaming (HTTP SSE) scenarios.
- AI Prompt Guard (opens in Plugin Hub docs)
- Introduced new plugin.
- Kafka Logger (opens in Plugin Hub docs)
- Supported reading the user request and response body content cached in
ctxand pushing it to the specified Kafka service.
- Supported reading the user request and response body content cached in
Data Plane
- Supported using values from an array object within the user request body in routing conditions. While
post_argwas already permitted in routing conditions, this update introduces support for array scenarios for the type field's location. - Supported the recording of additional AI request context information within access logs.
- Supported adding a request type identifier to Prometheus metrics to collect more granular data on AI requests.
Console (Dashboard)
- Added detailed statistics for service name and route name in status code alert messages.
- Optimized plugin configuration: When configuring Traffic Split (opens in Plugin Hub docs) plugin on a service or route, verify that the
upstream_idconfigured indeed belongs to the current service's upstreams. - Aligned the upstream connection configuration field names with the API in published services.
- Introduced a form-based UI for CORS (opens in Plugin Hub docs) plugin configuration.
Fixes
Data Plane
- Fixed issue: When the upstream type was Kubernetes service discovery, nodes in health checks were not updated after node changes, resulting in many health check failure logs.
- Fixed issue: An error occurred when the
shared_sizeparameter for Kubernetes service discovery was adjusted to 100m.#11857 - Fixed issue: APISIX/API7 Enterprise with Kubernetes discovery will fail after token file expires. #11779
- Fixed issue: After updating the
prefixof Vault secret provider, the data plane continued to use the old configuration.
Console (Dashboard)
- Fixed issue: The
retriesfield in the upstream was incorrectly set as required. - Fixed issue: An error occurred on the published service page due to lack of service template permissions.
- Fixed issue: Updating the service discovery service name in published services did not take effect.
- Fixed issue: Creating multiple records with rapid clicks.
- Fixed issue: High database CPU utilization when using large scale of consumers.
- Optimized the wildcard configuration method for Permission Policy:
- Wildcard configuration using
*is now supported in authorization statements, with the same meaning as the current<.*>; - The asterisk
*is restricted and not allowed in any resource ID fields to prevent authorization failures.
- Wildcard configuration using