Docs

API7 Gateway 3.8.10

SOAP — Introduced new plugin.

Release Date: 2025-08-25

Features

Plugins

Data Plane

  • Supported configuring the addresses for DP Manager and the Admin API via an API7 Dashboard configuration file.

Console (Dashboard)

  • Supported specifying the Admin API address in the gateway deployment configuration, which will be used to populate the GatewayProxy Endpoint address in the API7 Ingress Controller deployment script.
  • Consolidated allow_access API calls in the API7 Dashboard frontend to reduce redundant requests.
  • Added hash_on configuration item to upstream connection configuration.

Fixes

Plugins

  • AI Proxy Multi (opens in Plugin Hub docs)
    • Fixed issue: A panic was triggered by connection timeouts to the upstream service.
  • Removed the ext-plugin-pre-req, ext-plugin-post-req, and ext-plugin-post-resp plugins from the Enterprise Edition.

Data Plane

  • Fixed issue: A deadlock could occur when the Control Plane updates the service API due to insufficient database connections.
  • Fixed issue: Upon restarting, worker processes could load stale data from the master process. This could cause temporary request failures (e.g., 404 errors) for recently created or modified routes before the worker process synchronized the latest data from etcd.
  • Fixed issue: Etcd history compaction could trigger a full data load in APISIX, causing a significant performance impact on the etcd service, especially in environments with a large number of gateway nodes.

Console (Dashboard)

  • Fixed issue: A consumer could not be created when its permission policy was configured to grant all permissions based on labels.
  • Fixed issue: In the consumer list page, pagination would occasionally fail. Attempting to navigate to another page would result in a brief loading state, but the view would remain on the current page.