API7 Gateway 3.8.7
Limit Count Advanced — Added support for Redis Sentinel mode.
Release Date: 2025-07-17
Features
Plugins
- Limit Count Advanced (opens in Plugin Hub docs)
- Added support for Redis Sentinel mode.
Data Plane
- Supported component upgrade sequence control to ensure dp-manager waits for database migration before startup.
Console (Dashboard)
- Supported OpenAPI editor pre-fills previous data for service OpenAPI specifications, avoiding full re-entry for simple modifications.
- Supported configuring and enabling Content Security Policy (CSP) by default.
- Supported displaying both Gateway API and Ingress deployment scripts for Ingress Controller gateway groups.
Developer Portal
- Supported deleting developers in the Provider Portal.
- Introduced an "Application" resource to manage API product subscriptions and credentials at the application level.
Fixes
Plugins
- Zipkin (opens in Plugin Hub docs)
- Fixed issue:
zipkin_trace_idappeared garbled inaccess.log.
- Fixed issue:
- Forward Auth (opens in Plugin Hub docs)
- Fixed issue: Forwarding POST requests with
forward-authplugin may result in 504 errors caused by the request body being lost. Resolved by introducingextra_headers.
- Fixed issue: Forwarding POST requests with
Data Plane
- Fixed issue: Some Control Plane APIs (
/api/license,/api/system_infos,/api/developer-portal-url) could be accessed without authorization. - Fixed issue:
delay_encodecould only be used once per log line. - Fixed issue: Metrics failed to report after startup due to certificate issues.
Console (Dashboard)
- Fixed issue: Deleting source code while editing a custom plugin cleared the entire form.
Developer Portal
- Fixed issue: Unauthenticated users could see non-subscribable products after filtering for subscribed API products.
- Fixed issue: The "Clear All" button has been removed for API products with a single filter, as its function overlaps with selecting "All" conditions.